Knowledge Base

How to switch PHP versions on Plesk

This article describes how to use Plesk to change the active PHP version on an account.

Switching PHP versions using CageFS

  1. Log in to Plesk.
    If you do not know how to log in to your Plesk account, please see this article.
  2. In the left sidebar, click Websites & Domains:

    Plesk - Sidebar - Websites and Domains

  3. In options panel at the far right, click the PHP Selector icon.
    If the PHP Selector icon does not appear in the options panel at the far right, your server does not use CageFS. Please see the Switching PHP versions without CageFS section below.

  4. If there is more than one domain in the account, a dialog box is shown lisitng the avaialble domains. Select the desired domain from the Webspace list, then click the OK button.

  5. On the next page, select the desired version of PHP from the PHP Version listbox and then click the Set as current button.

Switching PHP versions without CageFS

Plesk has multiple PHP versions available, to switch between these versions, follow these steps:

  1. Log in to Plesk.
    If you do not know how to log in to your Plesk account, please see this article.
  2. In the left sidebar, click Websites & Domains:

    Plesk - Sidebar - Websites and Domains

  3. Click Hosting Settings:

    Plesk - Hosting Settings

  4. Under Web Scripting and Statistics, in the PHP support (PHP version) list box, select the PHP version you want to use:

    Plesk - Version switcher

  5. Click OK. The new setting takes effect immediately.

More Information

For more information about Plesk, please visit https://www.plesk.com.