Knowledge Base

How to view e-mail message headers

This article describes how to view the raw e-mail message headers using various client applications. You can use the information in message headers to help troubleshoot some types of e-mail problems.

About e-mail message headers

E-mail headers provide low-level details about a message, such as:

  • Who sent the message and from what server.
  • The path the message took to arrive at its destination.
  • Anti-spam testing results.

If you experience e-mail issues and open a support ticket with our Guru Crew, they may ask you to provide header data for one or more of your messages. To do this, follow the appropriate procedure below for your own e-mail client application.

Mozilla Thunderbird

To view a message's e-mail headers in Mozilla Thunderbird, follow these steps:

  1. Open the message in Thunderbird.
  2. On the View menu, click Headers, and then click All.
    • You can view the complete message, including headers and content, in a separate window suitable for copy-and-paste or saving to a file. To do this, on the View menu, click Message Source.
    • To save the message as an EML file, on the File menu, click Save As, and then click File. In the Save Message As dialog box, in the Name text box, type a name for the file, and then click Save.

Microsoft Outlook

To view a message's e-mail headers in Outlook, follow these steps:

  1. Open the message in Outlook.
  2. On the File menu, click Info, click Properties, and then look under Internet headers.
    To save the message as a MSG file, on the File menu, click Save As. In the Save As dialog box, in the File name text box, type a name for the file. In the Save as type list box, select Outlook Message Format (*.msg), and then click Save.

Microsoft Outlook Express and Windows Mail

To view a message's e-mail headers in Outlook Express or Windows Mail, follow these steps:

  1. Open the message in Outlook Express.
  2. On the File menu, click Properties.
  3. Click the Details tab.
    • You can view the complete message, including headers and content, in a separate window suitable for copying and pasting. To do this, on the Details tab, click Message Source.
    • To save the message as an EML file, on the File menu, click Save As. In the Save Message As dialog box, in the File name text box, type a name for the file. In the Save as type list box, select Mail (*.eml), and then click Save.

Apple (Mac) Mail

To view a message's e-mail headers in Apple (Mac) Mail, follow these steps:

  1. Open the message in Mac Mail.
  2. On the View menu, click Message, and then click Long Headers.
    • You can also view the complete message, including headers and content, in a separate window suitable for copying and pasting. To do this, on the View menu, click Message, and then click Raw Source. To return to the normal message view, on the View menu, click Message, and then click Original Content.
    • To save the message as an EML file, on the File menu, click Save As. In the Format list box, select Raw Message Source, and then click Save.

Webmail

Follow the appropriate procedure below for your preferred webmail application.

Horde

To view a message's e-mail headers in Horde, follow these steps:

  1. Open the message in Horde.
  2. Click the plus (+) icon, and then click View Source.
    To save the message as an EML file, click the plus (+) icon, and then click Save. In the Save File dialog box, in the Name text box, type a name for the file, and then click Save.
Roundcube

To view a message's e-mail headers in Roundcube, follow these steps:

  1. Open the message in Roundcube.
  2. In the main toolbar, click More, and then click Show source.
    To save the message as an EML file, in the main toolbar, click More, and then click Download (.eml). In the Save File dialog box, in the Name text box, type a name for the file, and then click Save.
SquirrelMail

To view a message's e-mail headers in SquirrelMail, follow these steps:

  1. Open the message in SquirrelMail.
  2. Under Options, click View Full Header.
    To save the message as a text file, click Download this as a file. In the Save File dialog box, in the Name text box, type a name for the file, and then click Save.