TLS and Cipher Suites Update December 2019

A2 Hosting takes cybersecurity seriously, and as a result, we’ve updated our encryption and security technologies so that all sites utilizing SSL certificates (aka HTTPS.) Our clients now have the ability to use TLS 1.3 for LiteSpeed servers.

Going forward, our sites with SSL certificates will no longer support TLS 1.0 or 1.1 due to security vulnerabilities associated with them. Most users will not feel any effects of this change. However, the restriction of TLS 1.0 and 1.1 will prevent users of legacy devices from reaching websites using SSL. 

While it is not recommended, if a site absolutely must have backward compatibility, there is a process to restoring compatibility to TLS 1.2. Please note that TLS 1.0 and 1.1 are severely compromised. Any attempt to do PCI compliance will fail, and site users may face warnings from browsers. 

Did you find this article helpful? Then you'll love our support. Experience the A2 Hosting difference today and get a pre-secured, pre-optimized website. Check out our web hosting plans today.