Knowledge Base

Do you support Outlook Express?

Outlook Express cannot connect using newer SSL versions so we do not support it. Please choose a modern e-mail client or use Webmail.