Mailing list recipients do not receive list messages

This article discusses a problem where mailing list recipients may not receive list messages, and how to resolve it.

  • The information in this article only applies to shared hosting and reseller hosting packages. Managed VPS and Dedicated servers are not affected.
  • The information in this article only applies after you have confirmed that non-mailing list messages are being delivered correctly. If other types of messages are also not being delivered, you are probably experiencing a different issue (for example, your account has been blacklisted for sending spam).
Table of Contents

Problem

When you send an outgoing message to a mailing list, the list recipients do not receive the message.

Cause

This problem occurs when the From header or Reply-To header in the outgoing message uses an e-mail address from a free e-mail provider (for example, Gmail, Hotmail, or Yahoo). Spammers often use this technique to send spam, so messages that do so are blocked.

Resolution

To resolve this issue, you must ensure that the From header and Reply-To header in your messages use e-mail addresses for which you have direct control (in other words, that use your domain name).

Additionally, messages submitted to your mailing list should use the mailing list address itself as the Reply-To address. Many e-mail providers block messages where a list member's e-mail address is the Reply-To address.

To configure these settings, follow these steps:

  1. Log in to cPanel.
    If you do not know how to log in to your cPanel account, please see this article.
  2. Open the Mailing Lists tool:
    • If you are using the Jupiter theme, on the Tools page, in the Email section, click Mailing Lists:

      cPanel - Email - Mailing Lists icon

    • If you are using the Paper Lantern theme, in the EMAIL section of the cPanel home page, click Mailing Lists:

      cPanel - Email - Mailing Lists icon

  3. Under Current Lists, locate the mailing list you want to configure, and then click Manage. The mailman General Options page appears.
  4. Under General list personality, locate Details for from_is_list, and then click Munge From.

    The Munge From option rewrites the From: header by replacing the poster's address with the mailing list's address.
  5. Under Reply-To: header munging, locate first_strip_reply_to, and then click Yes.
  6. Under Reply-To: header munging, locate reply_goes_to_list, and then click This list.
  7. Click Submit Your Changes.

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